MobileSubstrate Gets iOS 4.2.1 Compatibility; It's Cydia Turn Now

Some apps run code on the SpringBoard, so if any of it crashes, you're pretty much screwed. But, MobileSubstrate is a failsafe "SpringBoard.app" that will run in case of a SpringBoard crash. This saves you from SWOD's, etc, by temporarily disabling the code until SpringBoard reloads correctly. MobileSubstrate has been updated with iOS 4.2.1 compatibility.


You have first to jailbreak your device and enable SSH on iOS 4.2.1 using Redsn0w by following our guide posted here, then download this .deb pacakage from here and connect your device via SSH. Type the following in the terminal:
ssh root@[ip-address-ios-device]
Now login as root by entering “alpine” as password.

Once you have logged in, type the following:
dpkg-i / tmp/mobilesubstrate_0.9.3366-1_iphoneos-arm.deb
By the news about iOS 4.2.1 jailbreak and unlock, and iOS 4.2.1 compatibility for MobileSubstrate, it's now Cydia's turn to get iOS 4.2.1 compatibility, we'll have to wait just a bit until an official jailbreak is out followed by the new version of Cydia.

For more news coverage, you can follow us on Twitter or become a fan on our Facebook page, we will keep you updated with posts over the web.


If you found this post useful, dont forget to click the +1 button =>  

Follow GreenPois0n on Google+


blog comments powered by Disqus